[pHash-support] mpeg1 and mpeg2 codecs are partially working with pHash

Pratik Bhoir pbhoir at blue-efficience.com
Wed Oct 30 09:53:15 PDT 2013

Hello pHash team,

My company is searching for a video fingerprint technology to automate more
our processes.
Currently we are testing pHash open source for video hashing and depending
on the results we might be interested in buying pHash Pro licence.

We came across what looks like to be an issue that pHash is not calculating
enough hash (only one hash value, irrespective of length of the video)
values for
mpeg1 and mpeg2 codecs.

Brief description of the issue:

System : Ubuntu 12.04 LTS
phash 0.9.6 (configured only with --enable-shared option)
CImg 1.4.9 (installed directly from Ubuntu repository)
ffmpeg 2.1  (configured only with --enable-shared option)

I have also tried all available versions of ffmpeg with the same result.

Though I edited one file before testing video hash,
1. cimgffmpeg.cpp : I edited this file because initially I was getting
segfault while executing test_video.
                              I edited the function long
GetNumberVideoFrames(const char *file) and float fps(const char *filename),
in both functions I assigned AVformatContext *pFormatCtx = NULL; as
mentioned in one of the support archive and it worked. URL:

Using the examples provided in pHash package, all the video coding formats
that I have tested are working well except  mpeg1 and mpeg2.
I have tried different videos with various lengths(5min, 20min and 45 min)
but result is always one hash value for mpeg1 and mpeg2.

Can you please look upon this issue and tell me where is the problem?

Thank you for your time and help,

- Pratik
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.phash.org/pipermail/phash-support-phash.org/attachments/20131030/3fe4ac0c/attachment.htm>

More information about the pHash-support mailing list